#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$"
Local $sString = "me@too.dk" & @CRLF & _
                "me.too@meee.dk" & @CRLF & _
                "me-too@meee.dk" & @CRLF & _
                "me.too.tt@meee.dk" & @CRLF & _
                "me.too@meee.uk.dk" & @CRLF & _
                "me.too@meee.co.dk" & @CRLF & _
                "bumlebee@nukeit.com" & @CRLF & _
                "hammel.not.u@timi.net" & @CRLF & _
                "video@utf8.video" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                "Dont approve" & @CRLF & _
                "" & @CRLF & _
                "me,too@meee.dk" & @CRLF & _
                "me.too@meee,dk" & @CRLF & _
                "home@@viktory.com" & @CRLF & _
                "home@home,shop" & @CRLF & _
                "" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")