import Foundation
let pattern = #"^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
me@too.dk
me.too@meee.dk
me-too@meee.dk
me.too.tt@meee.dk
me.too@meee.uk.dk
me.too@meee.co.dk
bumlebee@nukeit.com
hammel.not.u@timi.net
video@utf8.video
Dont approve
me,too@meee.dk
me.too@meee,dk
home@@viktory.com
home@home,shop
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)