re = /^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$/m
str = 'me@too.dk
me.too@meee.dk
me-too@meee.dk
me.too.tt@meee.dk
me.too@meee.uk.dk
me.too@meee.co.dk
bumlebee@nukeit.com
hammel.not.u@timi.net
video@utf8.video
Dont approve
me,too@meee.dk
me.too@meee,dk
home@@viktory.com
home@home,shop
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end