package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b(11\d{6}|10\d{6}|\d{6}01)\n?){3,}`)
var str = `11001100
11101010
10010010
00101101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}