$re = '/(\b(11\d{6}|10\d{6}|\d{6}01)\n?){3,}/m';
$str = '11001100
11101010
10010010
00101101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);