re = /(\b(11\d{6}|10\d{6}|\d{6}01)\n?){3,}/m
str = '11001100
11101010
10010010
00101101'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end