using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s[^>]*href=(\""??)([^#\""][^\"" >]*?)\1[^>]*>(.*)<\/a>";
string input = @"<a href=""http://google.com""></a>
<a href=""#google""></a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}