$re = '/<a\s[^>]*href=(\"??)([^#\"][^\" >]*?)\1[^>]*>(.*)<\/a>/m';
$str = '<a href="http://google.com"></a>
<a href="#google"></a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);