re = /<a\s[^>]*href=(\"??)([^#\"][^\" >]*?)\1[^>]*>(.*)<\/a>/m
str = '<a href="http://google.com"></a>
<a href="#google"></a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end