const regex = /(?:(?:^|\s)(?=(?:[^\s-]*-){2})|(?!^)\G)[^\s-]*\K-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:^|\\s)(?=(?:[^\\s-]*-){2})|(?!^)\\G)[^\\s-]*\\K-', 'gm')
const str = `Coca-Cola Step-By-Step`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);