use strict;
my $str = 'Coca-Cola Step-By-Step';
my $regex = qr/(?:(?:^|\s)(?=(?:[^\s-]*-){2})|(?!^)\G)[^\s-]*\K-/mp;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";