#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xi)[ptkmnlswj]?" & @CRLF & _
"(?:(?<=w)[aei]|" & @CRLF & _
"(?<=[jt])[aeou]|" & @CRLF & _
"(?<=[pkmnls])[aeiou]|" & @CRLF & _
"(?<=\b)[aeiou])" & @CRLF & _
"(?:n(?![nm]?[aeiou]))?"
Local $sString = "#Sanity Checks:" & @CRLF & _
"---" & @CRLF & _
"toki pona" & @CRLF & _
"nanpa wan" & @CRLF & _
"toki li pona mama tuliwan sulisuli " & @CRLF & _
"mi olin e sina" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"#These should not work:" & @CRLF & _
"---" & @CRLF & _
"titijiji" & @CRLF & _
"tanna" & @CRLF & _
"nanma" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"#Some sentences from Wikipesija page for Linguistics:" & @CRLF & _
"---" & @CRLF & _
"toki Inli (kepeken toki Inli: EngLish) li toki suli." & @CRLF & _
"toki Inli li kama tan ma Piten. taso tenpo ni la jan li kepeken kin e toki Inli lon ma Mewika lon ma Kanata lon ma Oselija lon ma Nusilan. jan li toki kin e toki Inli lon ma ante mute. toki Inli li toki pi ma sike. toki Inli li jo e kepeken mute." & @CRLF & _
"---" & @CRLF & _
"a an e en i in o on u un" & @CRLF & _
"pa pan pe pen pi pin po pon pu pun" & @CRLF & _
"ta tan te ten ti tin to ton tu tun" & @CRLF & _
"ka kan ke ken ki kin ko kon ku kun" & @CRLF & _
"ma man me men mi min mo mon mu mun" & @CRLF & _
"na nan ne nen ni nin no non nu nun" & @CRLF & _
"sa san se sen si sin so son su sun" & @CRLF & _
"ja jan je jen ji jin jo jon ju jun" & @CRLF & _
"la lan le len li lin lo lon lu lun" & @CRLF & _
"wa wan we wen wi win wo won wu wun" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")