import re
regex = re.compile(r"""
[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?
""", flags=re.VERBOSE | re.IGNORECASE)
test_str = ("#Sanity Checks:\n"
"---\n"
"toki pona\n"
"nanpa wan\n"
"toki li pona mama tuliwan sulisuli \n"
"mi olin e sina\n"
"---\n\n"
"#These should not work:\n"
"---\n"
"titijiji\n"
"tanna\n"
"nanma\n"
"---\n\n"
"#Some sentences from Wikipesija page for Linguistics:\n"
"---\n"
"toki Inli (kepeken toki Inli: EngLish) li toki suli.\n"
"toki Inli li kama tan ma Piten. taso tenpo ni la jan li kepeken kin e toki Inli lon ma Mewika lon ma Kanata lon ma Oselija lon ma Nusilan. jan li toki kin e toki Inli lon ma ante mute. toki Inli li toki pi ma sike. toki Inli li jo e kepeken mute.\n"
"---\n"
"a an e en i in o on u un\n"
"pa pan pe pen pi pin po pon pu pun\n"
"ta tan te ten ti tin to ton tu tun\n"
"ka kan ke ken ki kin ko kon ku kun\n"
"ma man me men mi min mo mon mu mun\n"
"na nan ne nen ni nin no non nu nun\n"
"sa san se sen si sin so son su sun\n"
"ja jan je jen ji jin jo jon ju jun\n"
"la lan le len li lin lo lon lu lun\n"
"wa wan we wen wi win wo won wu wun\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")