// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xi)[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?").unwrap();
let string = "#Sanity Checks:
---
toki pona
nanpa wan
toki li pona mama tuliwan sulisuli
mi olin e sina
---
#These should not work:
---
titijiji
tanna
nanma
---
#Some sentences from Wikipesija page for Linguistics:
---
toki Inli (kepeken toki Inli: EngLish) li toki suli.
toki Inli li kama tan ma Piten. taso tenpo ni la jan li kepeken kin e toki Inli lon ma Mewika lon ma Kanata lon ma Oselija lon ma Nusilan. jan li toki kin e toki Inli lon ma ante mute. toki Inli li toki pi ma sike. toki Inli li jo e kepeken mute.
---
a an e en i in o on u un
pa pan pe pen pi pin po pon pu pun
ta tan te ten ti tin to ton tu tun
ka kan ke ken ki kin ko kon ku kun
ma man me men mi min mo mon mu mun
na nan ne nen ni nin no non nu nun
sa san se sen si sin so son su sun
ja jan je jen ji jin jo jon ju jun
la lan le len li lin lo lon lu lun
wa wan we wen wi win wo won wu wun
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}