import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(\\.+\\d*)";
final String string = "</a018620183616546 >\n"
+ "<src =45656456554522555.22222222222 >\n"
+ "558-5548-542\n"
+ "Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh\n"
+ "suyan8019@gmail.com\n"
+ "563822998@qq.com\n"
+ "suya64@yahoo.com\n"
+ "su_yan@wang.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}