// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(\.+\d*)").unwrap();
let string = "</a018620183616546 >
<src =45656456554522555.22222222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}