re = /\d+(\.+\d*)/m
str = '</a018620183616546 >
<src =45656456554522555.22222222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end