using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[\w-]+[^\w-]+){2}[\w-]+";
string input = @"This is c-a-t. It is fat. That is a dog. It looks like a log. Fat-cat dog_log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}