$re = '/^(?:[\w-]+[^\w-]+){2}[\w-]+/m';
$str = 'This is c-a-t. It is fat. That is a dog. It looks like a log. Fat-cat dog_log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);