re = /^(?:[\w-]+[^\w-]+){2}[\w-]+/m
str = 'This is c-a-t. It is fat. That is a dog. It looks like a log. Fat-cat dog_log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end