package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*=brve_(\d+)_p1,.*`)
var str = `value {building=…,item=brve_1_p1,...}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}