const regex = /.*=brve_(\d+)_p1,.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*=brve_(\\d+)_p1,.*', '')
const str = `value {building=…,item=brve_1_p1,...}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}