$re = '/.*=brve_(\d+)_p1,.*/';
$str = 'value {building=…,item=brve_1_p1,...}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);