using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?=(?<!\w)\w*\(ea\))[\w()]{7,8}(?:\s|$))[\w()]{7,8}";
string input = @"bbeabbbbbbb
whafdfadffasdfbb(ea)bbbbbbb
bb(ea)bbbbbbb asdfasd(fr)asdf
saikbb(ea)bh list starting with this
bb(ea)bh list starting with this
line ending with this bb(ea)bh
this is another line with bb(ea)bh that is matched
another line ddfk(ea) in middle";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}