const regex = /(?=(?=(?<!\w)\w*\(ea\))[\w()]{7,8}(?:\s|$))[\w()]{7,8}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?=(?<!\\w)\\w*\\(ea\\))[\\w()]{7,8}(?:\\s|$))[\\w()]{7,8}', 'gm')
const str = `bbeabbbbbbb
whafdfadffasdfbb(ea)bbbbbbb
bb(ea)bbbbbbb asdfasd(fr)asdf
saikbb(ea)bh list starting with this
bb(ea)bh list starting with this
line ending with this bb(ea)bh
this is another line with bb(ea)bh that is matched
another line ddfk(ea) in middle`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}