import Foundation
let pattern = #"(?=(?=(?<!\w)\w*\(ea\))[\w()]{7,8}(?:\s|$))[\w()]{7,8}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bbeabbbbbbb
whafdfadffasdfbb(ea)bbbbbbb
bb(ea)bbbbbbb asdfasd(fr)asdf
saikbb(ea)bh list starting with this
bb(ea)bh list starting with this
line ending with this bb(ea)bh
this is another line with bb(ea)bh that is matched
another line ddfk(ea) in middle
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)