using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""]).*?\1|({foo})";
string input = @"select {foo} from Table where {foo} = ""This is {foo} today"" or {foo} = 'this is {foo} tomorrrow' or {foo} = ""it's all '{foo}' to me!""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}