re = /(['"]).*?\1|({foo})/m
str = 'select {foo} from Table where {foo} = "This is {foo} today" or {foo} = \'this is {foo} tomorrrow\' or {foo} = "it\'s all \'{foo}\' to me!"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end