$re = '/([\'"]).*?\1|({foo})/m';
$str = 'select {foo} from Table where {foo} = "This is {foo} today" or {foo} = \'this is {foo} tomorrrow\' or {foo} = "it\'s all \'{foo}\' to me!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);