package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([01][0-9]|[2][0-3]):[0-5][0-9]-([01][0-9]|[2][0-3]):[0-5][0-9]`)
var str = `The time 11:30-18:30 is captured correctly.
The time 13:61-14:30 is not catured.
The time 13:30-14:99 is not catured.
The time 01:00-23:09 is captured correctly.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}