const regex = /([01][0-9]|[2][0-3]):[0-5][0-9]-([01][0-9]|[2][0-3]):[0-5][0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([01][0-9]|[2][0-3]):[0-5][0-9]-([01][0-9]|[2][0-3]):[0-5][0-9]', 'gm')
const str = `The time 11:30-18:30 is captured correctly.
The time 13:61-14:30 is not catured.
The time 13:30-14:99 is not catured.
The time 01:00-23:09 is captured correctly.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}