$re = '/([01][0-9]|[2][0-3]):[0-5][0-9]-([01][0-9]|[2][0-3]):[0-5][0-9]/m';
$str = 'The time 11:30-18:30 is captured correctly.
The time 13:61-14:30 is not catured.
The time 13:30-14:99 is not catured.
The time 01:00-23:09 is captured correctly.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);