using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{[^{]*?CSM\n.*?(?=\{|$)";
string input = @"{{c1: what is horticulture CSM}}
{{c2 : how much is production CSP}}
{{c3: which state rank 1st in horticulture CSP}}
{{c5: how to improve horticulture production CSM}}
{{c6: how much is production of fruits CSP}}
out of this above note 6 questions will be formed ( called as cards ) c1, c2. c3 and so on.
here is how my cards will look for C1. card 1: c1
{{c1: ...}}
how much is production CSP
which state rank 1st in horticulture CSP
how to improve horticulture production CSM
how much is production of fruits CSP
here is how my card will look for C2 . card 2 : C2
what is horticulture CSM
{{c2 : ... }}
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}