use strict;
my $str = '{{c1: what is horticulture CSM}}
{{c2 : how much is production CSP}}
{{c3: which state rank 1st in horticulture CSP}}
{{c5: how to improve horticulture production CSM}}
{{c6: how much is production of fruits CSP}}
out of this above note 6 questions will be formed ( called as cards ) c1, c2. c3 and so on.
here is how my cards will look for C1. card 1: c1
{{c1: ...}}
how much is production CSP
which state rank 1st in horticulture CSP
how to improve horticulture production CSM
how much is production of fruits CSP
here is how my card will look for C2 . card 2 : C2
what is horticulture CSM
{{c2 : ... }}
';
my $regex = qr/\{\{[^{]*?CSM\n.*?(?=\{|$)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}