import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{[^\\{]*?CSM\\n.*?(?=\\{|$)";
final String string = "{{c1: what is horticulture CSM}}\n\n"
+ "{{c2 : how much is production CSP}}\n\n"
+ "{{c3: which state rank 1st in horticulture CSP}}\n\n"
+ "{{c5: how to improve horticulture production CSM}}\n\n"
+ "{{c6: how much is production of fruits CSP}}\n\n\n"
+ "out of this above note 6 questions will be formed ( called as cards ) c1, c2. c3 and so on. \n\n"
+ "here is how my cards will look for C1. card 1: c1\n\n"
+ "{{c1: ...}}\n\n"
+ "how much is production CSP\n\n"
+ "which state rank 1st in horticulture CSP\n\n"
+ "how to improve horticulture production CSM\n\n"
+ "how much is production of fruits CSP\n\n\n\n"
+ "here is how my card will look for C2 . card 2 : C2\n\n"
+ "what is horticulture CSM\n\n"
+ "{{c2 : ... }}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}