#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:,\d+)*$"
Local $sString = "80092382" & @CRLF & _
"800" & @CRLF & _
"800,876" & @CRLF & _
"98672102,20192210" & @CRLF & _
"" & @CRLF & _
"Hey 01" & @CRLF & _
"987 blue" & @CRLF & _
"black 1 white" & @CRLF & _
"orange"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")