$re = '/^\d+(?:,\d+)*$/m';
$str = '80092382
800
800,876
98672102,20192210
Hey 01
987 blue
black 1 white
orange';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);