import re
regex = re.compile(r"^\d+(?:,\d+)*$", flags=re.MULTILINE)
test_str = ("80092382\n"
"800\n"
"800,876\n"
"98672102,20192210\n\n"
"Hey 01\n"
"987 blue\n"
"black 1 white\n"
"orange")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")