using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('(.*?)')";
string input = @"style=""background-image:url('https://images.bid.cars/29564785_603d9fda599c0/1.jpg')""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}