re = /('(.*?)')/m
str = 'style="background-image:url(\'https://images.bid.cars/29564785_603d9fda599c0/1.jpg\')"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end