$re = '/(\'(.*?)\')/m';
$str = 'style="background-image:url(\'https://images.bid.cars/29564785_603d9fda599c0/1.jpg\')"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);