import re
regex = re.compile(r"(,|\r?\n|\r|^)(?:\"([^\"]*(?:\"\"[^\"]*)*)\"|([^\",\r\n]*))", flags=re.MULTILINE | re.UNICODE | re.IGNORECASE)
test_str = "\"1\",\"test\",\"booth\",\"\",\"2024/09/11\",\"2024/08/20\",\"1000\",\"2000\",\"\",\"1\",\"プレミアムウォーター\",\"0\",\"\",\"\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")