re = /(,|\r?\n|\r|^)(?:"([^"]*(?:""[^"]*)*)"|([^",\r\n]*))/mi
str = '"1","test","booth","","2024/09/11","2024/08/20","1000","2000","","1","プレミアムウォーター","0","",""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end