using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{1,3}((\s|-))?\(?\d\d\d\)?|^\(?\d\d\d\)?)((\s|-))?\d\d\d((\s|-))?\d\d\d\d$";
string input = @"// These Should Work
1 123 321 1234
1 (123-321-1234
11233211234
1(123)321-1234
123-321-1234
1-123321-1234
1(123321-1234
// These Should Not
1111 123-321-1234
1 123 32112-34
1(123) -321-1234
1(123321123-4
12345678901234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}