# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\d{1,3}((\s|-))?\(?\d\d\d\)?|^\(?\d\d\d\)?)((\s|-))?\d\d\d((\s|-))?\d\d\d\d$"
test_str = ("// These Should Work\n"
" \n"
"1 123 321 1234\n"
"1 (123-321-1234\n"
"11233211234\n"
"1(123)321-1234\n"
"123-321-1234\n\n"
"1-123321-1234\n"
"1(123321-1234\n\n"
"// These Should Not\n\n"
"1111 123-321-1234 \n"
"1 123 32112-34\n"
"1(123) -321-1234\n"
"1(123321123-4\n"
"12345678901234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.