import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{1,3}((\\s|-))?\\(?\\d\\d\\d\\)?|^\\(?\\d\\d\\d\\)?)((\\s|-))?\\d\\d\\d((\\s|-))?\\d\\d\\d\\d$";
final String string = "// These Should Work\n"
+ " \n"
+ "1 123 321 1234\n"
+ "1 (123-321-1234\n"
+ "11233211234\n"
+ "1(123)321-1234\n"
+ "123-321-1234\n\n"
+ "1-123321-1234\n"
+ "1(123321-1234\n\n"
+ "// These Should Not\n\n"
+ "1111 123-321-1234 \n"
+ "1 123 32112-34\n"
+ "1(123) -321-1234\n"
+ "1(123321123-4\n"
+ "12345678901234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}