package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?:[01]\d|2[0-3]|[0-59]):[0-5]\d:[0-5]\d)|(^(?:[0-5]\d|2[123]|[0-59]):[0-5]\d)`)
var str = `00:00 Intro
01:03 Pricing and features -
03:14 - Practicality
1:25:00
05:44 Under the bonnet
06:51 - Driving
30:00 Test time length
11:04
11:21 Safety
11:46Test no space
12:20 Verdict
08:45: Test extra colon
12:40 + Test char +
12:45 . Test char .
4:22 - Test timestamp
1:25:00 Test trailing text
01:30:25 - Another chapter
1:30:25 - Another chapter
75:00
30:00
120
2
25
2:30 Chapter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}