import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:[01]\\d|2[0-3]|[0-59]):[0-5]\\d:[0-5]\\d)|(^(?:[0-5]\\d|2[123]|[0-59]):[0-5]\\d)";
final String string = "00:00 Intro\n"
+ "01:03 Pricing and features -\n"
+ "03:14 - Practicality \n"
+ "1:25:00\n"
+ "05:44 Under the bonnet\n"
+ "06:51 - Driving\n"
+ "30:00 Test time length\n"
+ "11:04\n"
+ "11:21 Safety\n"
+ "11:46Test no space\n"
+ "12:20 Verdict\n"
+ "08:45: Test extra colon\n"
+ "12:40 + Test char +\n"
+ "12:45 . Test char .\n"
+ "4:22 - Test timestamp\n"
+ "1:25:00 Test trailing text\n"
+ "01:30:25 - Another chapter\n"
+ "1:30:25 - Another chapter\n"
+ "75:00\n"
+ "30:00\n"
+ "120\n"
+ "2\n"
+ "25\n"
+ "2:30 Chapter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}