use strict;
my $str = '00:00 Intro
01:03 Pricing and features -
03:14 - Practicality
1:25:00
05:44 Under the bonnet
06:51 - Driving
30:00 Test time length
11:04
11:21 Safety
11:46Test no space
12:20 Verdict
08:45: Test extra colon
12:40 + Test char +
12:45 . Test char .
4:22 - Test timestamp
1:25:00 Test trailing text
01:30:25 - Another chapter
1:30:25 - Another chapter
75:00
30:00
120
2
25
2:30 Chapter';
my $regex = qr/(^(?:[01]\d|2[0-3]|[0-59]):[0-5]\d:[0-5]\d)|(^(?:[0-5]\d|2[123]|[0-59]):[0-5]\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}