# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\d\n]+).*/\1/gm;t' <<< "W1W
BT3
BS5
E1W
B68"